Dependendo do dispositivo Android, as imagens do ListView não aparecem

Pergunte sobre todos os tipos de dúvidas relacionadas ao desenvolvimento de aplicativos Windows, Mac, iOS e Android.

Moderador: hermeson

Flavio_CS
Mensagens: 6
Registrado em: 11/Mar/2016, 15:36

Dependendo do dispositivo Android, as imagens do ListView não aparecem

Mensagempor Flavio_CS » 08/Mai/2017, 03:59

Estou desenvolvendo um app para android que possui um ListView que utiliza imagens de um ImageList
Atribuo um campo integer de uma query ao ImageIndex, aplicando assim uma imagem especifica para cada item.
O problema e que quando rodo o app no meu cel (que já e meio antigo), funciona tudo corretamente.
Mas quando executei o app no cel do cliente, as imagens não apareciam.
Como devo proceder para garantir que as imagens apareçam em todos os tipos de dispositivos Android?
marcelbranco
Mensagens: 27
Registrado em: 16/Ago/2016, 17:30

Re: Dependendo do dispositivo Android, as imagens do ListView não aparecem

Mensagempor marcelbranco » 25/Jul/2017, 14:09

Flávio,

qual a versão do seu Delphi?
qual modelo e android do teu cliente?

estou tendo problemas tb de incompatibilidade com o componente tTimeEdit, no android 7.0(sansung S7).. mas ainda não consegui encontrar um pq disso.
emailx45
Mensagens: 171
Registrado em: 05/Ago/2016, 14:55

Re: Dependendo do dispositivo Android, as imagens do ListView não aparecem

Mensagempor emailx45 » 25/Jul/2017, 20:14

veja na embarcadero sobre Hotfix para Android (abril e junho 2017)

:ugeek:
Desde 1993 (Clipper) / Desde 1998 (Delphi) / Firebird é meu DB / Windows é meu ambiente / Intel é minha plataforma de fazer código :lol:
marcelbranco
Mensagens: 27
Registrado em: 16/Ago/2016, 17:30

Re: Dependendo do dispositivo Android, as imagens do ListView não aparecem

Mensagempor marcelbranco » 16/Ago/2017, 16:55

Baixei o HotFix e nada.

mas ao atualizar para o XE10.1 Berlin, esse erro não ocorre mais, funcionando perfeitamente.
emailx45
Mensagens: 171
Registrado em: 05/Ago/2016, 14:55

Re: Dependendo do dispositivo Android, as imagens do ListView não aparecem

Mensagempor emailx45 » 16/Ago/2017, 22:22

no blog do Marcos Cantu vc vera um artigo sobre a nova versao Rad Studio Xe10.2 RELEASE 1 e Microsft Windows Create Update q esta dando trabalho p Embarcadero e seus clientes.

A Microsoft tem mudado a forma de carregamento das DLL/BPL no caso de Delphi.leia o artigo.

https://community.embarcadero.com/blogs ... ium=social

isto aliado aos pobremas do XE10.2 TOKYO com aplicativos Android.

tente atualizar o NDK v14 + Tools e JAVA v8

https://developer.android.com/studio/index.html

https://developer.android.com/ndk/downloads/index.html

http://www.oracle.com/technetwork/java/ ... 33151.html

:ugeek:
Desde 1993 (Clipper) / Desde 1998 (Delphi) / Firebird é meu DB / Windows é meu ambiente / Intel é minha plataforma de fazer código :lol:

Voltar para “Dúvidas Gerais”

Quem está online

Usuários navegando neste fórum: Nenhum usuário registrado e 1 visitante